windows系统中IIS中没有装PHP Manager如何切换PHP版本

现在大家都有各种ECS,各式各样的服务器,我们都会安装一些支持各种的服务器组件,其中就有PHP组件,但是不是所有网站都可以用一个PHP,有的网站能用7.0,有的可以用5.6,甚至还有不少只支持5.2这就很尴尬了,其实有个软件叫PHP Manager ,如果用它就可以帮助我们来切换,具体看站内网站,Windows IIS PHP切换工具PHP Manager 1.5 for IIS 8.5, IIS 10 正式版 支持WIN10、Win2016、Win2019这个是支持高版本的,还有地版本的,依然是站内网站IIS安装 PHP Manager 此产品安装失败:已下载的文件未通签名验证这两个版本,一个可以支持2008-2012、另外一个1.5的支持2016-2019哦,如果我们不想安装PHP Manager如何来切换PHP呢,其实也很简单,具体请看;

先安装多个PHP版本,然后打开IIS网站(单一站点,不要全局哦),处理程序映射,映射FastCgi模块即可,具体请看图:

处理程序映射

按照以上的图,多个版本不能同时共存,只能你需求某个版本导入某个版本即可,

所写所说,是心之所感,思之所悟,行之所得;文当无敷衍,落笔求简洁。 以所舍,求所获;有所依,方所成!

更多请关注:老梁`s Blog

免责声明,若由于商用引起版权纠纷,一切责任均由使用者承担。 您必须遵守我们的协议,如果您下载了该资源行为将被视为对《免责声明》全部内容的认可->联系老梁投诉资源
Laoliang.Net资源全部来自互联网收集,仅供用于学习和交流,请勿用于商业用途。如有侵权、不妥之处,请联系站长并出示版权证明以便删除。 敬请谅解! 侵权删帖/违法举报/投稿等事物联系邮箱:service@laoliang.net
老梁`s Blog(老梁博客) » windows系统中IIS中没有装PHP Manager如何切换PHP版本

发表评论

本站承接,网站推广(SEM,SEO),软件的安装的安装与调试,服务器的推荐以及配置,APP的开发与维护,网络或者web维护;财务软件,客户管理系统,人力资源,超市POS,医药管理,服务器安全,ecshop,金蝶,用友,管家婆;

立即查看 了解详情