叮叮摩卡在win10安装时提示“已在此计算机上安装相同或更高版本的 .NET Framework 4”解决办法

今天一客户深夜就旺旺联系让帮安装net4.0,问他啥系统,客户说win10,那win10自带的就4.7了 咋可能还要继续安装4.0呢,毕竟4.7支持4.0往下兼容肯定的,如果还出现这样的问题,那估计就是其他net版本闹的鬼,先来看看客户的问题;先上图:

其实根据上图上来看,第一个提示基本无效,第二个才是真的提示,现在这个提示可以证明是往下兼容兼容不成功,

客户在百度中百度了一圈也没找到解决方式,我也确实没看到有啥有质量的提示,最多的都是ctrl+C+V,甚是无奈,现在我来说说如何解决的;

先说明一下,导致无法正常安装下去,并不是系统的问题, 请勿理解系统上出了问题,免得走了弯路;我们开始操作,安装在 控制面板-》程序和功能-》启用或关闭windows功能,里面有,如下图:

发现.NET Framework3.5是关闭状态(.NET Framework3.5是向后兼容的),其实也就是说,net高版本装了,低版本没有装的缘故,其实刚才错误的提示,并不是没有4,而是找不到基础包,比如1.0、2.0、3.5、这样,需要选中它的复选框,然后点击“确定”,如下图所示:

此刻提示从网上下载,再点击“从Windows更新下载文件”如下图:

点了上图的更新下载文件,就会自动安装了,请看下图:

所有请求完成了,看提示“windows 已完成请求的更改”如下图:

完成以上步骤,代表.NET Framework已经安装好了,再安装客户的叮叮摩卡就不再提示需要安装.NET Framework了;到此教程结束;

PS:其实很多问题,不要老盯着错的再哪里,可能是别的错误引起的这个错误,解决问题多方面的想就OK了;

后续:其实客户也想过卸载4.7安装4.0,说卸载不了,这是为啥呢?原因还在这里,请看以下文字:

在 Windows XP 不能卸载NET Framework 1.0 的选项,在 Windows Server 2003 上不能卸载 .NET Framework 1.1 ,在 Windows Vista 或 Windows Server 2008 不能卸载 .NET Framework 2.0 或 .NET Framework 3.0 的,这就说明.NET Framework 作为操作系统组件的操作系统版本上运行,是不允许卸载的,即使有些强制办法卸载了,也会引起各种大脑缺氧的身体不适;

同时也发布一个卸载net的软件,Microsoft .net framework Cleanup Tool是一款可以对电脑中的.Net进行清理的工具,常常会出现.net安装错误或者失败的情况,使用这款.Net Clean UP可以帮助您一键删除;支持以下版本:

.NET Framework 清理工具支持删除以下产品:

.NET Framework – All Versions

.NET Framework – All Versions (Tablet PC and Media Center)

.NET Framework – All Versions (Windows Server 2003)

.NET Framework – All Versions (Windows Vista and Windows Server 2008)

.NET Framework – All Versions (Windows 7)

.NET Framework 1.0

.NET Framework 1.1

.NET Framework 2.0

.NET Framework 3.0

.NET Framework 3.5

.NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

使用方法:一、下载完成后不要在压缩包内运行软件直接使用,先解压;二、 软件同时支持32位64位运行环境;三、 如果软件无法正常打开,请右键使用管理员模式运行。

Microsoft .NET Framework Cleanup Tool v2018.05中文版(点我即可下载)

延伸阅读:我在CSDN上看到了一篇有效的办法,同时也贴出来,怕文章丢失,我就截图了一下,同时也附上了链接(URL);

NET无法卸载教程

CSDN链接在这里:https://blog.csdn.net/qq_37327261/article/details/81068268

所写所说,是心之所感,思之所悟,行之所得;文当无敷衍,落笔求简洁。 以所舍,求所获;有所依,方所成!

更多请关注:老梁`s Blog

免责声明,若由于商用引起版权纠纷,一切责任均由使用者承担。 您必须遵守我们的协议,如果您下载了该资源行为将被视为对《免责声明》全部内容的认可->联系老梁投诉资源
Laoliang.Net资源全部来自互联网收集,仅供用于学习和交流,请勿用于商业用途。如有侵权、不妥之处,请联系站长并出示版权证明以便删除。 敬请谅解! 侵权删帖/违法举报/投稿等事物联系邮箱:service@laoliang.net
老梁`s Blog(老梁博客) » 叮叮摩卡在win10安装时提示“已在此计算机上安装相同或更高版本的 .NET Framework 4”解决办法

1 评论

  1. 你好 3.5的复选框已经是选中状态了 但是还是出现了安装4失败的问题怎么办 程序出错信息是一样的 该如何解决呢

发表评论

本站承接,网站推广(SEM,SEO),软件的安装的安装与调试,服务器的推荐以及配置,APP的开发与维护,网络或者web维护;财务软件,客户管理系统,人力资源,超市POS,医药管理,服务器安全,ecshop,金蝶,用友,管家婆;

立即查看 了解详情